Verily Patch Release Notes

Summary

Verily Patch 1.2 is the first public release.

Verily Patch 1.3 has enhanced functionality for customization of displays by deployment and improvements to visual design.

New Mobile Application Features

  • Pairing and setup of Verily Patch
  • Most recent temperature display
  • Device status display
  • High temperature threshold notifications
  • Unit of measure configuration
  • Connectivity notifications

iOS

Requirements:

  • iPad devices are not supported.
  • Requires iOS 13.3+

Known Issues:

  • If connecting to Verily Patch fails repeatedly after choosing “Try pairing again”, you should contact customer support for assistance.

Android

Requirements: 

  • Phones must support BLE 4.2+ and BLE secure connection pairing/bonding.

  • Requires Android 6.0+

Known Issues: 

  • If connecting to Verily Patch fails repeatedly after choosing “Try pairing again”, you should contact customer support for assistance.
  • The following phone models are not supported:  Galaxy Note 5, Huawei Nova 4e, Nexus 5X.

Please reach out to our support team at: patchsupport@verily.com or 833-821-7411 with any questions or concerns. Note: we will be closed December 24, 25, 31 and January 1.